ForHLR Environment Modules

From KIT HPC Wiki
(Redirected from Environment Modules)
Jump to: navigation, search
Description Content
module load category/name or category/name/version (optional)
Availability ForHLR II (fh2)
Links Lmod: A New Environment Module System
License GNU General Public License


1 Introduction

Environment Modules, or short Modules are the means by which most of the installed scientific software is provided on ForHLR system.
The use of different compilers, libraries and software packages requires users to set up a specific session environment suited for the program they want to run. ForHLR cluster provides users with the possibility to load and unload complete environments for compilers, libraries and software packages by a single command.

2 Description

The Environment Modules package enables dynamic modification of your environment by the use of so-called modulefiles. A modulefile contains information to configure the shell for a program/software . Typically, a modulefile contains instructions that alter or set shell environment variables, such as PATH and MANPATH, to enable access to various installed software.
One of the key features of using the Environment Modules software is to allow multiple versions of the same software to be used in your environment in a controlled manner. For example, two different versions of the Intel C compiler can be installed on the system at the same time - the version used is based upon which Intel C compiler modulefile is loaded.
The software stack of ForHLR cluster provides a number of modulefiles. You can also create your own modulefiles. Modulefiles may be shared by many users on a system, and users may have their own collection of modulefiles to supplement or replace the shared modulefiles.
A modulefile does not provide configuration of your environment until it is explicitly loaded, i.e., the specific modulefile for a software product or application must be loaded in your environment before the configuration information in the modulefile is effective.
If you want to see which modules are loaded you must execute 'module list'.

$ module list
Currently Loaded Modulefiles:
   1) dot   2) compiler/intel/18.0   3) numlib/mkl/2018   4) mpi/openmpi/3.1


3 Usage

On ForHLR II Lmod: A New Environment Module System from http://lmod.readthedocs.org/en/latest/ is installed.

3.1 Documentation

Execute 'module help' or 'man module' for help on how to use Modules software.

$ module help
Usage: module [options] sub-command [args ...]

Options:
  -h -? -H --help                   This help message
  -s availStyle --style=availStyle  Site controlled avail style: system (default: system)
  -D                                Program tracing written to stderr
  --debug=dbglvl                    Program tracing written to stderr
  --pin_versions=pinVersions        When doing a restore use specified version, do not follow defaults
  -d --default                      List default modules only when used with avail
  -q --quiet                        Do not print out warnings
  --topic=topic                     help topics: modfuncs envvars
  --expert                          Expert mode
  -t --terse                        Write out in machine readable format for commands: list, avail, spider, savelist
  --initial_load                    loading Lmod for first time in a user shell
  --latest                          Load latest (ignore default)
  --ignore_cache                    Treat the cache file(s) as out-of-date
  --novice                          Turn off expert and quiet flag
  --raw                             Print modulefile in raw output when used with show
  -w twidth --width=twidth          Use this as max term width
  -v --version                      Print version info and quit
  -r --regexp                       use regular expression match
  --gitversion                      Dump git version in a machine readable way and quit
  --dumpversion                     Dump version in a machine readable way and quit
  --localvar=localvarA              local variables needed to be set after this commands execution
  --check_syntax --checkSyntax      Checking module command syntax: do not load
  --config                          Report Lmod Configuration
  --mt                              Report Module Table State
  --timer                           report run times
  --force                           force removal of a sticky module or save an empty collection
  --redirect                        Send the output of list, avail, spider to stdout (not stderr)
  --no_redirect                     Force output of list, avail and spider to stderr
  --show_hidden                     Avail and spider will report hidden modules
  --spider_timeout=timeout          a timeout for spider

module [options] sub-command [args ...]

Help sub-commands:
------------------
  help                              prints this message
  help                module [...]  print help message from module(s)

Loading/Unloading sub-commands:
-------------------------------
  load | add          module [...]  load module(s)
  try-load | try-add  module [...]  Add module(s), do not complain if not found
  del | unload        module [...]  Remove module(s), do not complain if not found
  swap | sw | switch  m1 m2         unload m1 and load m2
  purge                             unload all modules
  refresh                           reload aliases from current list of modules.
  update                            reload all currently loaded modules.

Listing / Searching sub-commands:
---------------------------------
  list                              List loaded modules
  list                s1 s2 ...     List loaded modules that match the pattern
  avail | av                        List available modules
  avail | av          string        List available modules that contain "string".
  spider                            List all possible modules
  spider              module        List all possible version of that module file
  spider              string        List all module that contain the "string".
  spider              name/version  Detailed information about that version of the module.
  whatis              module        Print whatis information about module
  keyword | key       string        Search all name and whatis that contain "string".

Searching with Lmod:
--------------------
  All searching (spider, list, avail, keyword) support regular expressions:

  spider -r           '^p'          Finds all the modules that start with `p' or `P'
  spider -r           mpi           Finds all modules that have "mpi" in their name.
  spider -r           'mpi$         Finds all modules that end with "mpi" in their name.

Handling a collection of modules:
--------------------------------
  save | s                          Save the current list of modules to a user defined "default" collection.
  save | s            name          Save the current list of modules to "name" collection.
  reset                             The same as "restore system"
  restore | r                       Restore modules from the user's "default" or system default.
  restore | r         name          Restore modules from "name" collection.
  restore             system        Restore module state to system defaults.
  savelist                          List of saved collections.
  describe | mcc      name          Describe the contents of a module collection.

Deprecated commands:
--------------------
  getdefault          [name]        load name collection of modules or user's "default" if no name given.
                                    ===> Use "restore" instead  <====
  setdefault          [name]        Save current list of modules to name if given, otherwise save as the default list for you the user.
                                    ===> Use "save" instead. <====

Miscellaneous sub-commands:
---------------------------
  show                modulefile    show the commands in the module file.
  use [-a]            path          Prepend or Append path to MODULEPATH.
  unuse               path          remove path from MODULEPATH.
  tablelist                         output list of active modules as a lua table.

Important Environment Variables:
--------------------------------
  LMOD_COLORIZE                     If defined to be "YES" then Lmod prints properties and warning in color.

    ------------------------------------------------------------------------------------------------------------------
The following guides are at http://lmod.readthedocs.org/

  User Guide                 - How to use.
  Advance User Guide         - How to create you own modules.
  System Administrator Guide - How to install Lmod on your own system.
    ------------------------------------------------------------------------------------------------------------------

Modules based on Lua: Version 6.1.3  2016-02-11 06:02
    by Robert McLay mclay@tacc.utexas.edu

For help on particular version of Module, e.g. Intel default compiler version, execute 'module help compiler/intel'.

$ module help compiler/intel
----------- Module Specific Help for 'compiler/intel/18.0' ---------------------------

Intel(R) Compilers 18.0 for Linux*
For details see: https://software.intel.com/en-us/intel-compilers
In case of problems, please contact: Hartmut Häfner <hartmut.haefner@kit.edu>
SCC support end: 2020-12-31


3.1.1 Online Documentation

Lmod: A New Environment Module System

3.2 Display all available Modules

Available Module are modulefiles that can be loaded by the user. A Module must be loaded before it provides changes to your environment, as described in the introduction to this section. You can display all available Modules on the system by executing:

$ module avail

The short form the command is:

$ module av

Available Modules can be also displayed in different modes, such as

  • each Module per one line
$ module -t avail

Some modules may not be available right now, because their requirements are not met. To get a complete list of all possible modules use the module spider command.

3.3 Module categories, versions and defaults

The ForHLR clusters traditionally provide a large variety of software and software versions. Therefore Module are divided in category folders containing subfolders of modulefiles again containing modulefile versions, and must be addressed as follows:

category/softwarename/version

For instance all versions of the Intel compiler belong to the category of compilers, thus the corresponding modulefiles are placed under the category compiler and intel.
In case of multiple software versions, one version will be always defined as the default version. The Module of the default can be addressed by simply omitting the version number:

category/softwarename


3.4 Finding software Modules

Currently all ForHLR software packages are assigned to the following Module categories:

  • bio
  • cae
  • chem
  • compiler
  • devel
  • math
  • mpi
  • numlib
  • phys
  • system
  • vis

You can selectively list software in one of those categories using, e.g. for the category "compiler"

$ module avail compiler/

Searches are looking for a substring starting at the begin of the name, so this would list all software in categories starting with a "c"

$ module avail c

while this would find nothing

$ module avail hem


3.5 Loading Modules

You can load a Module software in to your environment to enable easier access to software that you want to use by executing:

$ module load category/softwarename/version

or

$ module add category/softwarename/version

Loading a Module in this manner affects ONLY your environment for the current session.

3.5.1 Loading conflicts

You can not load different versions of the same software at the same time! Loading the Intel compiler in version X while Intel compiler in version Y is loaded leads to an automatic unloading of Intel compiler in version Y.

3.5.2 Showing the changes introduced by a Module

Loading a Module will change the environment of the current shell session. For instance the $PATH variable will be expanded by the software's binary directory. Other Module variables may even change the behavior of the current shell session or the software program(s) in a more drastic way.

All the changes to the current shell session to be invoked by loading the Module can be reviewed using
'module show category/softwarename/version'.

Example (Intel compiler)

$ module show compiler/intel
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
   /software/all/lmod/modulefiles/Core/compiler/intel/18.0.lua:
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
setenv("INTEL_LICENSE_FILE","28518@scclic1.scc.kit.edu")
setenv("AR","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64/xiar")
setenv("CC","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64/icc")
setenv("CXX","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64/icpc")
setenv("F77","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64/ifort")
setenv("FC","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64/ifort")
setenv("CFLAGS","-O2 -xCORE-AVX2")
setenv("CXXFLAGS","-O2 -xCORE-AVX2")
setenv("FFLAGS","-O2 -xCORE-AVX2")
setenv("FCFLAGS","-O2 -xCORE-AVX2")
setenv("INTEL_VERSION","18.0.5.274")
setenv("INTEL_HOME","/opt/intel/compilers_and_libraries_2018/linux")
setenv("INTEL_BIN_DIR","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64")
setenv("INTEL_LIB_DIR","/opt/intel/compilers_and_libraries_2018/linux/lib/intel64")
setenv("INTEL_INC_DIR","/opt/intel/compilers_and_libraries_2018/linux/include")
setenv("INTEL_MAN_DIR","/opt/intel/compilers_and_libraries_2018/linux/man/common")
setenv("INTEL_DOC_DIR","/opt/intel/compilers_and_libraries_2018/linux/documentation/en")
setenv("GDB_VERSION","18.0.5.274")
setenv("GDB_HOME","/opt/intel/debugger_2018/gdb/intel64")
setenv("GDB_BIN_DIR","/opt/intel/debugger_2018/gdb/intel64/bin")
setenv("GDB_LIB_DIR","/opt/intel/debugger_2018/libipt/intel64/lib")
setenv("GDB_INC_DIR","/opt/intel/debugger_2018/gdb/intel64/include")
setenv("GDB_INF_DIR","/opt/intel/documentation_2018/en/debugger/gdb-ia/info")
setenv("GDB_MAN_DIR","/opt/intel/documentation_2018/en/debugger/gdb-ia/man")
setenv("KMP_AFFINITY","noverbose,granularity=core,respect,warnings,compact,1")
prepend_path("PATH","/opt/intel/compilers_and_libraries_2018/linux/bin/intel64")
prepend_path("MANPATH","/opt/intel/compilers_and_libraries_2018/linux/man/common")
prepend_path("LD_LIBRARY_PATH","/opt/intel/compilers_and_libraries_2018/linux/lib/intel64")
whatis("Sets up Intel C/C++ and Fortran compiler version 18.0 (Intel(R) Compilers 18.0 for Linux*) - supported by SCC till 2020-12-31!")
help([[Intel(R) Compilers 18.0 for Linux*
For details see: https://software.intel.com/en-us/intel-compilers
In case of problems, please contact: Hartmut Häfner <hartmut.haefner@kit.edu>
SCC support end: 2020-12-31]])
prepend_path("MODULEPATH","/software/all/lmod/modulefiles/Compiler/intel/18.0")
family("compiler")

'module show' does not load the Module!

3.5.3 Modules depending on Modules

Some program Modules depend on libraries to be loaded to the user environment. Therefore the corresponding Modules of the software must be loaded together with the Modules of the libraries.
By default such software Modules try to load required Modules and corresponding versions automatically.


3.6 Unloading Modules

To unload or remove a software Module execute:

$ module unload category/softwarename/version

or

$ module remove category/softwarename/version


3.6.1 Unloading all loaded modules

3.6.1.1 Purge

Unloading a Module that has been loaded by default makes it inactive for the current session only - it will be reloaded the next time you log in.
In order to remove all previously loaded software modules from your environment issue the command 'module purge'.
Example

$ module list
Currently Loaded Modules:
  1) dot   2) compiler/intel/18.0   3) numlib/mkl/2018   4) mpi/openmpi/3.1
$
$ module purge
$ module list
No modules loaded
$ 

Beware!
'module purge' is working without any further inquiry.

3.7 Display your loaded Modules

All Modules that are currently loaded for you can be displayed by the command 'module list'. See example above.
Note: You only have to load further Modules, if you want to use additional software packages or to change the version of an already loaded software.

3.8 Display all possible Modules

Modulefiles can be searched by the user. You can dipslay all possible modules by executing:

$ module spider 

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
The following is a list of the modules currently available:
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  cae/abaqus: cae/abaqus/2019
  cae/ansys: cae/ansys/17.2, cae/ansys/2020R1
  cae/lsdyna: cae/lsdyna/901
  cae/openfoam: cae/openfoam/v1712, cae/openfoam/v1806, cae/openfoam/v1812, cae/openfoam/v1906_64, cae/openfoam/v1906, cae/openfoam/v1912, cae/openfoam/3.0.1, cae/openfoam/4.1, cae/openfoam/5_64, ...
  cae/starccm+: cae/starccm+/13.06.011, cae/starccm+/14.02.010
  cae/starcd: cae/starcd/4.26
  chem/cp2k: chem/cp2k/3.0-popt, chem/cp2k/3.0-psmp, chem/cp2k/3.0-sopt, chem/cp2k/5.1-popt, chem/cp2k/5.1-psmp, chem/cp2k/5.1-sopt, chem/cp2k/5.1-ssmp
  chem/dalton: chem/dalton/2016
  chem/dftb+: chem/dftb+/18.2
  chem/gromacs: chem/gromacs/2016.3-impi, chem/gromacs/2016.3-ompi, chem/gromacs/2016.5-impi, chem/gromacs/2016.5-ompi, chem/gromacs/2018.1-impi, chem/gromacs/2018.1-ompi, chem/gromacs/2018.2-ompi, ...
  chem/lammps: chem/lammps/16Mar18, chem/lammps/30Jul16
  chem/molden: chem/molden/5.6
  chem/namd: chem/namd/2.13
  chem/nwchem: chem/nwchem/6.6r27746mx, chem/nwchem/6.8mx
  chem/omen: chem/omen/trunk
  chem/plumed: chem/plumed/2.5.3
  chem/siesta: chem/siesta/3.2, chem/siesta/4.0
  chem/tmolex: chem/tmolex/4.3, chem/tmolex/4.3.2, chem/tmolex/4.4
  chem/turbomole: chem/turbomole/7.2, chem/turbomole/7.2.1, chem/turbomole/7.3
  chem/vasp: chem/vasp/5.4.1, chem/vasp/5.4.4, chem/vasp/6.1.0
  compiler/clang: compiler/clang/5.0, compiler/clang/6.0, compiler/clang/7.0, compiler/clang/8.0
  compiler/gnu: compiler/gnu/4.8.5, compiler/gnu/6, compiler/gnu/7, compiler/gnu/8, compiler/gnu/9
  compiler/intel: compiler/intel/17.0, compiler/intel/18.0, compiler/intel/19.0, compiler/intel/19.1
  compiler/pgi: compiler/pgi/2019
  devel/APS: devel/APS/2018
  devel/advisor: devel/advisor/2017, devel/advisor/2018
devel/binutils: devel/binutils/2.31.1
  devel/cmake: devel/cmake/2.8, devel/cmake/3.4, devel/cmake/3.5, devel/cmake/3.6, devel/cmake/3.7, devel/cmake/3.9, devel/cmake/3.11, devel/cmake/3.12, devel/cmake/3.13, devel/cmake/3.14
  devel/cube: devel/cube/4.4
  devel/cuda: devel/cuda/9.0, devel/cuda/10.0, devel/cuda/10.1
  devel/ddt: devel/ddt/18.2, devel/ddt/19.0
  devel/devtoolset: devel/devtoolset/3, devel/devtoolset/4
  devel/dimemas: devel/dimemas/5.4.0
  devel/eclipse: devel/eclipse/4.4, devel/eclipse/4.5, devel/eclipse/4.6
  devel/extrae: devel/extrae/3.6.1
  devel/inspector: devel/inspector/2017, devel/inspector/2018
  devel/itac: devel/itac/2018
  devel/jdk: devel/jdk/1.7.0_79, devel/jdk/1.8.0_92
  devel/julia: devel/julia/0.5.0
  devel/maqao: devel/maqao/2.6.4
  devel/netbeans: devel/netbeans/8.2
  devel/oprofile: devel/oprofile/1.3.0
  devel/papi: devel/papi/5.6.0
  devel/paraver: devel/paraver/4.8.0
  devel/perf: devel/perf/4.19.1
  devel/python: devel/python/2.7, devel/python/3.5, devel/python/3.6
  devel/scalasca: devel/scalasca/2.4
  devel/scorep: devel/scorep/4.1
  devel/tau: devel/tau/2.27.2p1
  devel/tv: devel/tv/2017.3.8
  devel/vtune-ampl: devel/vtune-ampl/2017.3, devel/vtune-ampl/2018.1
  dot: dot
  lib/cdo: lib/cdo/1.8.2
  lib/hdf5: lib/hdf5/1.8_serial, lib/hdf5/1.8, lib/hdf5/1.10_serial, lib/hdf5/1.10
  lib/nco: lib/nco/4.6.7, lib/nco/4.7.9
  lib/ncview: lib/ncview/2.1.8
  lib/netcdf: lib/netcdf/4.6
  lib/netcdf-cxx4: lib/netcdf-cxx4/4.3
  lib/netcdf-fortran: lib/netcdf-fortran/4.4
  math/R: math/R/3.4.1
  math/matlab: math/matlab/R2016a, math/matlab/R2016b, math/matlab/R2017a, math/matlab/R2017b, math/matlab/R2018a, math/matlab/R2018b, math/matlab/R2019a, math/matlab/R2019b, math/matlab/R2020a
  mpi/impi: mpi/impi/2017, mpi/impi/2018, mpi/impi/2019
  mpi/mvapich2: mpi/mvapich2/2.2, mpi/mvapich2/2.3
  mpi/openmpi: mpi/openmpi/1.10, mpi/openmpi/2.1, mpi/openmpi/3.0, mpi/openmpi/3.1, mpi/openmpi/4.0
  numlib/OpenBLAS: numlib/OpenBLAS/0.2.20, numlib/OpenBLAS/0.3.3
  numlib/fftw: numlib/fftw/3.3_serial, numlib/fftw/3.3
  numlib/gsl: numlib/gsl/1.16, numlib/gsl/2.1, numlib/gsl/2.2, numlib/gsl/2.3, numlib/gsl/2.4, numlib/gsl/2.5
  numlib/mkl: numlib/mkl/2017, numlib/mkl/2018, numlib/mkl/2019, numlib/mkl/2020
  system/parbatch: system/parbatch/1.0
  system/ssh_wrapper: system/ssh_wrapper/0.1
  vis/Ensight: vis/Ensight/101
  vis/Paraview: vis/Paraview/5.2.0, vis/Paraview/5.6.1-osmesa, vis/Paraview/5.6.1, vis/Paraview/5.8.0-osmesa, vis/Paraview/5.8.0
  vis/turbovnc: vis/turbovnc/2.2.4
  vis/visit: vis/visit/2.10.3
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

'module spider modulename' : You can search using a modulename. The search lists all possible versions of that module.

$ module spider gnu

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  compiler/gnu:
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     Versions:
        compiler/gnu/4.8.5
        compiler/gnu/6
        compiler/gnu/7
        compiler/gnu/8
        compiler/gnu/9

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  For detailed information about a specific "compiler/gnu" module (including how to load the modules) use the module's full name.
  For example:

     $ module spider compiler/gnu/9
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

'module spider string' : You can search using a string. The search lists all modules which contain "string"

$ module spider net

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  devel/netbeans: devel/netbeans/8.2
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    This module can be loaded directly: module load devel/netbeans/8.2

    Help:
      The NetBeans IDE is a world-class development environment written in
      Java. It can be used to develop code in Java, HTML, XML, JSP, C/C++,
      and other languages. The IDE is modular and there is a huge variety of
      commercial and free extensions for it that support various
      technologies.
      
      


-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  lib/netcdf:
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     Versions:
        lib/netcdf/4.6

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  For detailed information about a specific "lib/netcdf" module (including how to load the modules) use the module's full name.
  For example:

     $ module spider lib/netcdf/4.6
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  lib/netcdf-cxx4:
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     Versions:
        lib/netcdf-cxx4/4.3

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  For detailed information about a specific "lib/netcdf-cxx4" module (including how to load the modules) use the module's full name.
  For example:

     $ module spider lib/netcdf-cxx4/4.3
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  lib/netcdf-fortran:
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
     Versions:
        lib/netcdf-fortran/4.4

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  For detailed information about a specific "lib/netcdf-fortran" module (including how to load the modules) use the module's full name.
  For example:

     $ module spider lib/netcdf-fortran/4.4
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Moreover, you can see the dependencies of the module with using the same command. For example, if the following is executed, you can see which modules need to be loaded before loading the module mpi/openmpi/3.1

$ module spider mpi/openmpi/3.1

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  mpi/openmpi: mpi/openmpi/3.1
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    You will need to load all module(s) on any one of the lines below before the "mpi/openmpi/3.1" module is available to load.

      compiler/clang/7.0
      compiler/clang/8.0
      compiler/gnu/6
      compiler/gnu/7
      compiler/gnu/8
      compiler/gnu/9
      compiler/intel/17.0
      compiler/intel/18.0
 
    Help:
      Open MPI (http://www.openmpi.org) is an open source implementation of the
      Message Passing Interface specification (http://www.mpi-forum.org/) developed
      and maintained by a consortium of research, academic, and industry partners.
      
      Open MPI also includes an implementation of the OpenSHMEM parallel
      programming API (http://www.openshmem.org/).  OpenSHMEM is a
      Partitioned Global Address Space (PGAS) abstraction layer, which
      provides fast inter-process communication using one-sided
      communication techniques.
      
      This RPM contains all the tools necessary to compile, link, and run
      Open MPI and OpenSHMEM jobs.
      
      To select an OpenMPI version with Valgrind support, the environment variable
      VALGRIND must be set to true before loading the module:
      export VALGRIND=true
      
      In case of problems, please contact: Hartmut Häfner <hartmut.haefner@kit.edu>
      SCC support end: As soon as this version is declared as "Older version" on
                       the website http://www.openmpi.org/software/ompi     


4 How do Modules work?

The default shell on the ForHLR II is bash, so explanations and examples will be shown for bash. In general, programs cannot modify the environment of the shell they are being run from, so how can the module command do exactly that?
The module command is not a program, but a bash-function. You can view its content using:

$ type module

and you will get the following result:

$ type module
module is a function
module () 
{ 
    eval $($LMOD_CMD bash "$@");
    [ $? = 0 ] && eval $(${LMOD_SETTARG_CMD:-:} -s sh)
}

In this function, lmod is called. Its output to stdout is then executed inside your current shell using the bash-internal eval command. As a consequence, all output that you see from the module is transmitted via stderr (output handle 2) or in some cases even stdin (output handle 0).


Back to top